WordPress发布5.6新版本

WordPress发布5.6新版本

WordPress 5.6正式版发布了,WordPress 5.6是2020年计划的最终主要发布版本,于2020年12月8日发布,它包括一些主要功能和更新,以及大量的次要增强功能和错误修复。作为该年度的第三大主要WordPress核心版本。WordPress 5.6的重点是改进WordPress块编辑器,增强安全性(特别是扩展自动更新)。一些更改对安全性和兼容性具有直接影响,我们在本文中已针对WordPress用户进行了重点介绍。

WordPress 5.6主要功能更新和改进

  1. WordPress核心版本自动更新
  2. 从古腾堡插件中添加的块编辑器更新
  3. 更多的块模式
  4. 新的默认二十一二十一主题
  5. 封面视频位置控件
  6. 字符数
  7. 封面块的背景图案
  8. 将多个块转换为列块
  9. 支持视频字幕
  10. 首选项模式中的新设置
  11. 站点运行状况检查改进

对开发人员的改进

  1. 应用密码
  2. jQuery更新
  3. 兼容支持PHP 8
  4. REST API更新
  5. New Block API,版本2

WordPress核心版本自动更新

在WordPress 5.5中添加的插件和主题的自动更新之后,WordPress 5.6现在提供了一个新的UI,可以为WordPress核心版本发布打开自动更新。WordPress核心自动更新功能已在WordPress中存在多年,但是WP 5.6仅引入了新的用户界面,以使加入主要版本WordPress的自动更新更加容易。

WordPress版本发行版通常包含重要的安全补丁来关闭漏洞(只需查看WordPress漏洞摘要中每个月披露了多少主题和插件的安全问题)。因此,始终运行最新版本的WordPress或您网站上安装的任何插件或主题都是最重要的WordPress安全最佳做法之一。

现在,WordPress允许您在网站后台的控制台 > 更新页面 自动更新。启用自动更新后,您不再需要在WordPress管理控制台的“更新”页面上手动更新WordPress。这样,您始终可以知道您的站点正在运行最新的可用代码。

使用WordPress 5.6,管理员用户可以使用“更新”屏幕上的特定界面来选择加入/退出主要WordPress版本的自动更新,如下所示:

从古腾堡插件中添加的块编辑器更新

WordPress块编辑器(也称为Gutenberg)的快速改进在WordPress 5.6中仍在继续。

实际上,WordPress 5.6捆绑了七个最新版本的WordPress Gutenberg插件(8.6到9.2)。进入WordPress核心。

WordPress 5.6中包含的块编辑器改进示例包括(我们将在其各自的部分中详细介绍其中的每一个):

  • 更大的布局灵活性–更多工具可让您使用或不使用代码来编辑布局。单列块,使用混合宽度和列的设计,全宽页眉以及封面中的视频-轻松进行小改动或大声明!
  • 更多的阻止模式–在选定主题中,预配置的阻止模式使在您的站点上轻松设置标准页面变得容易。寻找模式的力量来简化您的工作流程,或与客户分享其中的一些力量,并节省一些点击次数。
  • 直接在块编辑器中上传视频字幕–为了帮助您向视频中添加字幕,现在您可以在帖子或页面中上传字幕。这样,比以往任何时候都更容易使需要或喜欢使用字幕的任何人都可以访问您的视频。
  • 利用块编辑器的新窗口小部件屏幕与您使用块编辑器编辑页面和帖子的方式保持一致。
  • 导航块(水平和垂直) –这些新块使您可以将菜单添加到帖子或页面
  • 完全站点编辑(FSE) –尝试完全站点编辑的最佳方法是使用带有Gutenberg插件的新的主题。

WordPress块模式是即插即用的预定义WordPress块布局。块模式是一组WordPress块,允许用户通过单击几个按钮来创建任意数量的复杂布局。

块模式首次作为WordPress 5.5的主要功能之一推出,为WordPress块编辑器成为完整的页面构建器铺平了道路。块模式旨在帮助用户一起使用块组合,以实现其页面的最佳设计。

可以使用任何帖子或页面上的块编辑器中的“ +”图标找到块模式。在搜索栏下方,切换到“图案”选项卡。

封面视频位置控件

现在可以调整视频背景在Cover块中的位置。以前,这些定位控件仅适用于图像背景。焦点选择器和输入控件都支持光标和键盘交互。

字符数

现在,您可以在信息面板中查看帖子或页面的字符数。信息面板当前包括单词,标题,段落和块的计数,以及带有标题的文档大纲。

封面块的背景图案

如果您的主题支持,现在可以为封面添加重复的背景设置。从媒体库设置图像后,您将看到该块媒体设置的新“重复背景”设置。从那里,您可以玩一个焦点选择器。

将多个块转换为列块

WordPress 5.6中添加的一个整洁的工作流程项是将多个块转换为列块的功能。例如,您可以选择三个图像并将它们变成三列块。

支持视频字幕

为了帮助您向视频中添加字幕,您现在可以将其上传到视频块的帖子或页面中。这样,比以往任何时候都更容易使需要或喜欢使用字幕的任何人都可以访问您的视频。

首选项模式中的新设置

如果您使用“帖子”或“页面”编辑器右上方的3点小菜单,则“首选项”将出现一个新的设置模式。此模式包括一些新的有用设置,例如预发布清单,键盘和外观设置以及文档设置的自定义设置,这些设置可以帮助您缩小在块编辑器中看到的选项。

站点运行状况检查改进

随着WordPress 5.6的发布,站点运行状况组件处理和验证运行状况检查的方式已添加了许多增强功能。这些改进中的大多数都不会在您的站点的前端上被注意到,但是很好地提醒您,WordPress中存在此有用的工具来访问您站点的健康状况。

对开发人员的改进

WordPress 5.6具有许多以开发人员为中心的更新。以下是一些注意事项:

应用密码

借助API的新应用密码授权功能,第三方应用可以无缝安全地连接到您的网站。这项新的REST API功能使您可以查看哪些应用程序正在连接到您的站点并控制它们的工作。

应用程序密码允许独立的应用程序更轻松地访问WordPress。

当5年前添加REST API时,希望使用WordPress的移动应用程序会大量涌现,但这并没有发生。

应用程序密码应该有所帮助。

这是完整的《应用程序密码:集成指南》,使您阅读愉快。

jQuery更新

WordPress中jQuery的更新涵盖三个版本:5.5、5.6和5.7。达到此过程的中点后,您仍然需要运行更新测试插件来提前检查您的网站是否存在错误。

2020年8月发布的WordPress 5.5删除了jQuery Migrate脚本。这导致许多使用依赖旧版本jQuery的插件的网站出现问题。

如果您的网站受到影响,并且您当前正在使用Enable jQuery Migrate Helper插件来解决这些问题,那么在更新到WordPress 5.6之前,您需要确保没有它的网站也能正常工作。

这是因为WordPress 5.6将更新到最新版本的jQuery并添加了jQuery Migrate 3.3.2,这可能与Enable jQuery Migrate Helper插件(即jQuery Migrate 1.4.1)重新启用的版本冲突。

WordPress几年来一直在使用jQuery库的过时版本。

WordPress 5.6是3步计划的第2步,旨在使WordPress升级到最新版本的jQuery。该计划是:

  • WordPress 5.5:删除jQuery Migrate 1.x脚本。(2020年8月)
  • WordPress 5.6:更新到最新的jQuery,jQuery UI和jQuery Migrate脚本。(2020年12月)
  • WordPress 5.7:删除jQuery Migrate脚本。(2021年3月)

由于这个时间表,jQuery兼容性实际上比PHP 8.0兼容性迫切得多。插件和主题开发人员应该在WordPress 5.7发行之前的接下来的几个月中使用它们,以完全过渡其代码以与最新版本的jQuery兼容,而无需jQuery Migrate的帮助。

尽管已将安全修复程序移植到早期WordPress版本所使用的jQuery版本中,但许多工具(例如Google的Lighthouse)已报告WordPress网站由于运行旧版本的jQuery而容易受到攻击。好消息是,这些网站审核工具不应再显示WordPress 5.6网站容易受到攻击。

在WordPress 5.6期间,默认情况下,迁移脚本将保持启用状态,以捕获已弃用功能的任何意外使用。

  • 概述了一个三步计划,计划于 2020年6月升级与WordPress核心捆绑在一起的jQuery版本。
  • 在 jQuery的核心升级指南 提供了哪些功能被弃用,拆除,以及如何相应地升级你的代码的详细信息。
  • 这是有关将核心jQuery更新到版本3 –第2部分的更多信息

支持PHP 8

WordPress 5.6标志着向PHP 8的WordPress核心支持迈出了第一步。尽管它仍然很新,但PHP 8.0是PHP语言的主要更新。它包含许多新功能和优化。

WordPress 5.6旨在与PHP 8“ beta兼容”。这意味着,在正常使用情况下,使用默认主题在PHP 8上运行WordPress 5.6且没有插件的网站不太可能会遇到任何问题。我们的前一篇文章深入探讨了插件作者在与PHP 8兼容时将面临的一些挑战。

如果您是使用大量插件的典型WordPress网站所有者,则可能需要一段时间才能安全更新到PHP8。另一方面,如果您是从头开始创建全新的网站,则需要通过从最新版本的PHP和WordPress开始,可以解决许多问题。

总之,WordPress 5.6包含了许多更改,改进和错误修复,其中包括许多我们没有涵盖的内容。我们专注于我们认为与用户最相关且最有可能引起问题的项目。与WordPress的所有主要更新一样,是否要立即更新取决于您的用例。有许多有希望的新功能以及潜在的成长隐患,但这些功能将适用于开发人员而非用户。

WordPress 5.6 更新升级

方法一:在WordPress网站后台的 【 仪表盘> 更新 】 页面,直接在线更新;

方法二:在WordPress官方网站下载最新版,通过FTP上传更新;下载地址:https://wordpress.org/download/

分享到 :
相关推荐

发表评论

登录... 后才能评论